HUGO old version install on MacOS M3 (Apple Silicon)

Recently Im running into this big issue about install old version HUGO to my new laptop (MacBook Pro M3)
First of all I found I cannot use following brew command to install directly as before and got some errors:

brew install hugo@v0.65.3

Warning: No available formula with the name "hugo@v0.65.3".

==> Searching for similarly named formulae and casks...

Error: No formulae or casks found for hugo@v0.65.3.

Secondly, when I try to install it from source code by downloaded source code to local as hugo_0653.rb and installed it via “brew install hugo_0653.rb”, then again got these err:

The 4.2.0 release notes are available on the Homebrew Blog:
The 4.2.8 changelog can be found at:
Error: hugo-0653: undefined method `cellar' for #<BottleSpecification:0x000000010725caa8 @rebuild=0, @repository="/opt/homebrew", @collector=#<Utils::Bottles::Collector:0x000000010725c850 @tag_specs={}>, @root_url_specs={}>

I googled relevant issue but no clear solution and less results. Does anyone meet above before and any idea how install old version directly from source code ?

Any input would be greatly appreciated!!!


Brew does not retain formulas that are that old. Download the relevant binary from the Hugo repository releases page.

1 Like

@jmooring Thanks Joe. The last solution I’ve tried is downloaded from hugo 0.65.3 · Homebrew/homebrew-core@4256670 · GitHub w/ version as .rb, and used

brew install

also tried with hugo_0653.rb which is downloaded to local.

brew install hugo_0653.rb

Did I miss something? How could I execute HUGO with binary files?


I have no idea if that will run on your current system.

@jmooring I downloaded hugo_0.65.3_macOS-64bit.tar.gz
There is one unix executable calls “Dockerfile”. Is there any document that guide me to install and via binary on MacOS?

I’m not sure what you’re doing, but you’re doing it wrong. If you download and extract, the structure is:

└── hugo*

@jmooring It’s my fault, I have tried couple methods and messed with other folder.
What I going to do is install old version (0.65.3) on new MacBook Pro M, but failed as homebrew don’t have that old formula, so going to try installing with binary as you suggested. When I ran unix executable, I got the following error:

And checked with our IT, we can not change System Preferences → Security & Privacy to allow it download.

Is there another way make that installation? Thanks @jmooring

Sure, you can build from source. But if you’re having trouble installing a simple executable, I think you’ll have even more problems building from source.

Since you have an IT resource, I suggest you work with them directly.

1 Like

Thanks a lot for your quick response. @jmooring