Hugo 0.27 Released!


#1

Spread the word.


#2

The Snap & 3rd-Party Releases


Hugo Snap - a Hugo Snap package - not yet updated
Docker Hugo - a Hugo Docker image - updated
Fedora Copr - Hugo rpm packages for Fedora and CentOS - updated


#3

I got some mail about the Snap builder having some problems. I have started a new build now; let us see how that goes.


#4

This is awesome - tnx. I really like the chaining feature for config files. Great work!


#5

Hello,

The Fedora Copr has been updated to v0.27.


#6

As a related discussion over at the homebrew repo, they say that Hugo was installed 8100 times from Brew just in the last 30 days…

Hugo is number 82 …


#7

Updated my post. Seems like the Hugo Snap still isn’t updated though. :confused:

Holy crap. I can’t image that many people installing something that’s been out for so long. So impressive.


#8

I agree, I had to go back and check:

There maybe something about that number I don’t understand, but it is at least indicative.


#9

To be fair, that probably includes people running brew upgrade (or whatever their upgrade command is). Basically anyone who installed Hugo through homebrew at some point in time and keeps their system fairly up-to-date. It’s not like these people keep an eye on gohugo.io and saw that there was a new version available and just had to grab a copy.

That said, 8100 people using Hugo through Homebrew is still a very good number. Great to see so much interest in the project… it’s always painful to see open-source projects you like die off from lack of interest, it looks like that won’t happen to Hugo any time soon :slight_smile:


#10

This is great! I was super excited to see better Related-Content support. However, I was unable to get the custom configurations working.

I added this to my single page template as recommended in the Release Notes:

{{ $related := .Site.RegularPages.Related . | first 5 }}
{{ with $related }}
<h3>See Also</h3>
<ul>
	{{ range . }}
	<li><a href="{{ .RelPermalink }}">{{ .Title }}</a></li>
	{{ end }}
</ul>
{{ end }}

It worked as expected. However, I attempted to add some custom configuration (as described in the Related Content section). Something like this:

[related]
includeNewer = true

And whether I use “true” or “false”, simply adding this [related] portion in my config.toml actually makes that part of the template stop working (the entire “See Also” section disappears). I feel like something weird is happening and I wanted to see if it happened to anyone else before I dig deeper?

Thanks!

EDIT: Ahhh, I know what’s wrong. I figured out that I cannot pick and choose the config options. I had initially wanted to change only the includeNewer, but it ended up resetting the rest of the options. I needed to add a set of [[related.indices]] to get it working again. Works great now!