Hugo 0.19 stuck on 'Started building sites'

Just as the title says.

I’m running hugo on a Mac with the latest updates : 10.12.3 (16D32)

It goes on forever and doesn’t show any sign of producing the html.
As this happened to anyone else?

Can you include the command line and any output it writes to the terminal?

Yes sure, but it’s scarce …

 ✘ $ ~/Labs/Digital-Insanity >  hugo server
Started building sites ...
  1. Does it build with an earlier version of Hugo?
  2. Does “hugo -v” give more info?

I suspect there is an infinite loop going on, which is hard to guess without seeing the project.

Ok, now I have more information …

Used a different computer where Hugo was working. Updated Xcode, and it was still working ( Xcode 8.3 includes Swift 3.1 and SDKs for iOS 10.3, warchOS 3.2, tvOS 10.2 and macOS Sierra 10.12)

I tested again, Hugo was working.

Then I ran the App Store update for MacOS Sierra:

Since that, the problem is back.

@bep, the output for -v is this:

INFO 2017/03/29 23:49:47 Using config file:
INFO 2017/03/29 23:49:47 using a UnionFS for static directory comprised of:
INFO 2017/03/29 23:49:47 Base: /Users/brunoamaral/Labs/Digital-Insanity/themes/light/static
INFO 2017/03/29 23:49:47 Overlay: /Users/brunoamaral/Labs/Digital-Insanity/static/
INFO 2017/03/29 23:49:47 syncing static files to /
WARN 2017/03/29 23:49:51 Translation func for language en not found, use default.
WARN 2017/03/29 23:49:51 i18n not initialized, check that you have language file (in i18n) that matches the site             language or the default language.
Started building sites ...
INFO 2017/03/29 23:49:51 found taxonomies: map[string]string{"tag":"tags", "category":"categories", "series":"series"}

There have been some other issues with macOS updates breaking Go binaries:

But they do not match yours.

I have a AppStore Update ready for my MacBook, but part of me do not want to break my setup, even if I then could reproduce this …

Could you run the failing hugo again with --stepAnalysis to see if it gets any more info?

Well, this is odd.

Just opened up the computer where this first started and ran the command. Everything is working now. :sweat:

I’m going to keep an eye out for any similar problems and if it doesn’t happen again in the next few days I’ll mark the thread as solved.

This is intermittent and I am a bit lost on how to proceed. :frowning:


This is also happening on the ubuntu server:
Linux DeLorean 3.13.0-36-generic #63-Ubuntu SMP Wed Sep 3 21:30:07 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Hugo Static Site Generator v0.19 linux/amd64 BuildDate: 2017-02-27T12:38:34Z

I’m starting to think it may be related to the svg files I have on the static directory. Will try later to rever to a previous commit and see what happens.

Do you use getJSON?

A downgrade to Hugo 0.18 or wait a couple of days for 0.20 should do it if that is the case.

The only mention of getJSON I have is in my javascript, could that be the case?

Further uses shown that the problem sometimes does not present itself, which makes me think this may be related to the memory available. Which is odd because my development machine has 8GB of ram.


1 Like