How to install Hugo on RPi Zero

I’m trying to install hugo on a Raspberry Pi Zero, it is running on buster.

I tried two methods but neither worked.

First I tried installing from source but I am unsure how to get the hugo command to work,
it says hugo: command not found
I tried following this thread, but I’m not sure where the binary for hugo is.

I then tried installing using the .deb file found on this site.
Running the following commands:
curl -O

sudo dpkg -i hugo_0.55.6+really0.54.0-1_armhf.deb

hugo version
Prints: Illegal Instruction

I looked at this issue, and the .deb file I’m installing has the -1.
I also looked at this, but the architecture of my pi zero is armhf.

Any help on where the binary for hugo can be found or why the second method doesn’t work
would be appreciated.

You can find it via locate hugo. This command will list all local paths that have hugo in them. You might have to run sudo updatedb before or even install these tools if they don’t come automatically in your system.

Indeed, the RPi cpu is ARM11 based. Did you try the ARM binary?

You might need to cross-compile the Hugo source on a Linux or Windows platform. Cross-compiling with Go is really easy. I believe the Zero is ARM 32 v6.

Thanks for the response. I crossed compiled and it worked. Thanks!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.