How do I use hugo extended on netlify?

The FAQ says:

To build hugo-extended, use go install --tags extended

But… where? Surely not locally, since the website runs locally just fine. Where am I supposed to put this for the online version?

Netlify always uses the extended version.

1 Like

Then why do I keep getting

$ hugo Start building sites … hugo v0.103.0-beebf2afb09a7be36cf12bdec8a99ae9286504e2 linux/amd64 BuildDate=2022-09-15T16:23:56Z VendorInfo=gohugoio Error: Error building site: TOCSS: failed to transform "scss/style.scss" (text/x-scss). Check your Hugo installation; you need the extended version to build SCSS/SASS.: this feature is not available in your current Hugo version, see for more information

Are you sure this is Netlify?

sorry that’s a message from gitlab’s CI/CD, is there something I gotta set up on that side?

It sounds like you build your site on GitLab, and then you build it again on Netlify.

Is that correct?

Hi Joe, I removed the .gitlab-ci.yml file now, the problem is that the site is not being rendered properly when built through netlify, which led me to suspect it wasn’t using hugo extended, because the theme specifically says the site won’t render properly without extended.

Perhaps you could be… specific.

it’s supposed to look like this:

And it looks like this:

I don’t know how to troubleshoot this beyond the basic assumption I made about SASS/SCSS not rendering correctly.

To be clear, when I render the site locally it looks like the first example.

EDIT i think my issue is with DNS, but i can’t find the culprit, in any case it’s probably not relevant to hugo

When I visit and open the browser’s dev tools:

Every asset is preceded by

yeah that’s what I saw, that’s supposed to be the real url. I’m double checking the DNS settings on netlify and on the domain provider, and I can’t find what’s wrong.

I set it up poorly initially, so maybe the settings on the domain provider are just taking very long to update.

What’s the baseURL in your site configuration?

It used to be, i now left it blank and it is working. Thats strange but i’ll take it

That is not a valid baseURL. Leaving it blank is not valid either. Do this instead:

baseURL = ''

It must contain protocol and trailing slash.

thank you for the guidance, it’s now working fully

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.