Home page showing full path

#1

Hi there, apologies if this has been answered elsewhere, but I did look first and found nothing similar.

I have built the beginnings of a developer portal for my company and the first page has an absolute URL of developer.mycompany.com/overview. At the moment, when I open developer.mycompany.com in a browser it resolves to the full URL. How do I get rid of the ‘overview’ bit of the URL in the browser? I have already set baseURL in config.toml in project directory/themes to be without the overview bit.

Thanks,

Matt

#2

For future reference: Double posting the same issue on GitHub + This forum is not how to get attention. We are the same people following both, so double the work.

#3

Thanks for the clarity on this forum versus GitHub. I’ll take what you say on board for future reference. However, please be aware I wasn’t trying to ‘get attention’ beyond having my question answered at some point.

#4

Read our getting help suggestions, and post a link to yer source. :slight_smile:

#5

Sorry, I don’t understand? Of course I’ve read all the documentation first. Do you think I’m an idiot? The only reason I’m here is because I’m STUCK!

#6

Can you paste a link to your source?

#7

Please don’t bring that energy here. The only reason I am here is because I find meaning in helping others, but rhetoric like that saps my energy.

The link I provided has guidance on the best ways to get support here, and linking to your repo is the fastest way someone will be able to help you figure out your deployment issue. Good luck. :slight_smile:

1 Like
#8

Please accept my sincerest apologies. I was having a bad day and the generic response irked me somewhat. I’m sorry if I caused any offence. I’m a technical writer but come from a non-developer background so some things in Hugo aren’t that obvious to me.

#9

Hi Rick, unfortunately I’m not able to share the source (or output) due to restrictions from my company. Thanks for the offer anyway :slight_smile:

#10

If you can’t share the source, then the next best step is to describe how you are deploying it (meaning which server or service is hosting your site), and paste your config here; you can obscure the meaningful info in it.

If you could do a tree in your content directory, that would be helpful too.

Please explain that: is that a theme option, or are you configuring a piece of content to resolve your home page to that URL?

#11

You could create a github gist and share anonymized versions of the relevant files.

Also, it could be the webserver’s settings that’s forcing that url-path or, an .htaccess file doing a redirect, if Apache (or some equivalent of that on other webservers).