Generation of pages fails on Gitlab

I have not made an update for about 3 months. Everything worked back then.

Now I just added new .md files, ie. content, changed a couple of lines in a shortcode file and now the site gets generated and deployed like this on Gitlab:

There are supposed to be blog posts showing up. I have already reverted back to the previous commit, but I get the same issue. I have not changed anything in the config, nor on Gitlab.

# .gitlab-ci.yml

image: monachus/hugo


  - hugo
    - public
  - master

This config for gitlab has also not changed. Just verified that it’s still the same (from the Docs)

Does anyone have any clues what’s happening? Thanks you.

Maybe try changing to monachus/hugo:v0.56.3 just to troubleshoot? This exact problem happened to me as well after updating to 0.57.0. This probably isn’t applicable to you, but just for reference I added these lines to config.toml a while ago (can’t remember why, to be honest) and removing them fixed this for me:

  tag = ""
  category = ""

It could also have to do with the changes to .Pages even though this was apparently reverted for now in 0.57.2. I updated my list.html as well to be safe.

Sorry I can’t be more help but I thought I should document my personal solution on here just in case it applies. :slight_smile:

1 Like

Fixed! Awesome, Jake! Thank you.

Adding v0.56.3 fixed the issue.

No problem! You’ll probably want to upgrade to a newer version at some point so I’d still try to figure this out but I’m glad your site is back up and running for now!

@cerrone, @jakejarvis solved upgrade issues for ya, but if you want to know why the newer version is nerfing yer site, make sure to share your code repo. :slight_smile:

You did solve the problem by downgrading to an older version, congratulations :wink:

If you want to solve the problem: I think it might be that you range over .Site.Pages but should range over .Site.RegularPages. Search for these here on the forum. That was the reason for most “suddenly empty posts” in 0.57.