Footnote followed by links doesn't work

Just right now I noticed that Hugo doesn’t process well this:

Bla bla [^1] [Access-Control-Allow-Origin][allow]


[^1]: This is a footnote


It only translates the link (I get the same result if I use an inline link instead), and preserves the footnote like plain text:

Bla bla [^1]⁣ Access-Control-Allow-Origin

(I just needed to use an invisible separator here (⁣), because the forum either process the link correctly just with spaces).

After a quick search, I found this similar bug issue in Blackfriday (similar, not the same, I think), made by @bjornerik , marked already solved and merged.
I use Hugo directly from AUR package, that uses the last (stable?) release, from 22 february (v0.13), so I guess it doesn’t has still that fix.
So… I wanted to ask if that fix already solves also this bad behaviour or not. Just for know if I only has to waiting for hugo next release or if I should file a new issue about this in Blackfriday’s github (because I guess it’s a blackfriday issue, right?). It’s there someone already running a Hugo dev version so kind to answer this question to me? If it isn’t a trouble, you know ;). I could build it from source myself, after read and understand all that go stuff, but it seems a little overkill task to me, more when I’m already dealing with the problem using the mentioned invisible character workaround :þ.

Many thanks for your time (please, don’t beat me xD).

Just tested this with latest Hugo + Blackfriday, and this is another bug in Blackfriday, just as you described.

1 Like

Many thanks, @bjornerik! :D.
I will file a github issue then ;).