Font change doesn't take effect while hugo server is running

I’m invoking hugo server --disableFastRender to run the server but when I change font of body text of blog posts, the changes won’t get applied.

  • I’ve tried refresh and hard-refresh on browser but didn’t work
  • The fonts are getting loaded from Google Fonts.

I have to exit the server and re-run it, then refresh the page to see the changes.
Is this a bug or expected behavior or am I doing something wrong?

Please try hugo server --noHTTPCache


Thanks. Would I need --disableFastRender also? Would I need any other switch so that hugo re-loads properly on change?

Please experiment on your own, and then post again if you have further questions.

I just tested hugo server --noHTTPCache and hugo server --noHTTPCache --disableFastRender. It still doesn’t get updated with font changes (even with Ctrl+Shift+R). The original lone --disableFastRender switch also didn’t work.

Hugo Static Site Generator v0.74.1-15163266/extended linux/amd64 BuildDate: 2020-07-13T19:02:45Z

Please post a link to the public repository for your site. See:

Include a link to the source code repository of your project, because we really need the context of seeing your templates and partials to be able to help you. It is trivial to do a quick git clone on your repo, then run hugo server in your project, to help you out. On the other hand, recreating your code from screenshots, or sort of guessing at it, is not.

If you can’t share your repository for whatever reason, consider creating a dummy repo that you can share, which reproduces the problem you’re experiencing.