disableAliases not preventing aliases for posts even when no aliases defined

I would like to prevent certain posts from having aliases created. These posts are all using a custom front matter array named pages. For details, see my post: https://jimfrenette.com/2019/03/hugo-content-with-pages-nav/

This all works great using the local in memory server, e.g., hugo server -D

However, I launched my site earlier this week and the page ones did not have any content, just a header and footer. Upon further discovery I found that aliases were being created for them and I don’t have a single alias defined in front mater for any of my posts.

Note this is only affecting the first pages for each of these.

Here is a log snippet for one of these unwanted aliases:

DEBUG 2019/05/16 11:29:10 creating alias: /2018/08/completely-blank-no-css-_s-wordpress-starter-theme/page/1/index.html redirecting to https://jimfrenette.com/2018/08/completely-blank-no-css-_s-wordpress-starter-theme/

here is the front matter for one of the page one markdown files in my content/posts directory:

title: 'Completely Blank (no css) _s WordPress Starter Theme'
date: Wed, 08 Aug 2018 02:12:56 +0000
draft: false
tags: [Sass, Tutorials, Webpack, WordPress]
slug: 'completely-blank-no-css-_s-wordpress-starter-theme'
pages: [

For now, I created the html files manually using view source of local hugo server versions until I can get this fixed.

Here is some more info on my setup if needed:

hugo version
Hugo Static Site Generator v0.55.5-A83256B9 linux/amd64 BuildDate: 2019-05-02T13:03:36Z

config snippet

  "languageCode": "en-US",
  "title": "JimFrenette.com",
  "theme": "cooldog",
  "disableAliases": true,
  "pluralizeListTitles": false,
  "permalinks": {
    "post": "/:year/:month/:slug"

You are using pagination: https://gohugo.io/templates/pagination/#additional-information

So the second line in the docs in your case: post/page/1/index.html redirects to post/index.html

Thanks for the comment - I have resolved the issue which appears to have been due to content items created with the same folder structure as the post permalink settings which caused these extra page generations. To resolve the issue, I deleted these items, e.g., content/2019/05/2/some-post.md and instead used a slug with the trailing page number, e.g., some-post/2
The post I linked to in my original post above has been updated as well so hopefully no one else experiences the same issue.