Bug? emojify vs. spaces and other characters

My Shortcode:

{{ .Get 0 | emojify }}

Used in an index.md

{{<emojify ":see_no_evil::hear_no_evil::speak_no_evil:" >}}


🙈 :hear_no_evil: 🙊

Having spaces between the three emojis results in the same. Is this a bug or something that can’t be changed? Of course, I can work over by using the shortcode three times. But I felt it worth mentioning…


{{<emojify ":see_no_evil:" >}}
{{<emojify ":hear_no_evil:" >}}
{{<emojify ":speak_no_evil:" >}}

See my post, it’s not about how, but why. Interesting too, that your quote came out properly.

check the generated HTML files.

What you see depends the used fonts!

What’s your hugo version?

0.54 on Linux.

I realized, that I had enableEmoji set to true in my config. Using the emojis without shortcode works as expected (with or without spaces around the colons).

Setting enableEmoji to false results in the same issue (middle emoji is not transformed) AND in addition, the paragraph where the shortcode is used appears fat (shortcode is at the end of the paragraph).

This might even not be a bug in the emoji handling but the .Get 0 handling. Does :: have any meaning in Markdown?

I could set enableEmoji to true and not use the shortcode, but then all 2000 posts would have to be parsed as opposed to one single post having emojis right now. That might be a performance issue.

I don’t think so. “modern” browsers should use utf8 characters for fonts that don’t have emojis? Also, whoever is creating a font with two of three monkeys shall roast in hell :laughing:



i tried some no-evil emojies and can reproduce your error!
post it as error on github (hugo / blackfriday??)