Authentication failed on Academic-kickstart Hugo project

Hi all,

I just deployed this theme (Academic theme) using Netlify as described by the docs. The site works and is up.

I then cloned the repository from github to my local machine.

When I tried to make a change locally and push my changes I get an authentication failure. With what credentials do I have to log in?

Doesn’t my default github account have push rights to this repo?

 ➜  git push
Username for '': 
Password for '':
remote: Invalid username or password.
fatal: Authentication failed for ''

Please show the output of git remote -v

Here is the output for git remote -v

➜  git remote -v
origin (fetch)
origin (push)

Edit .git/config. Under [remote "origin"] change:

url =


url =


If you’re using HTTP for authenticated pushing, providing your credentials is sometimes more complicated than using keys over SSH.

Changed the url

 ➜  vim .git/config

Tried to push

 ➜  git push Permission denied (publickey).
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

It doesn’t even ask me to authenticate myself now

If that doesn’t lead you in the right direction, please raise a question within the GitHub community:

I have fixed the issue by generating a new personal access token (PAT). I have written about this issue here:

Basically, everything works now except for the fact that it keeps prompting me on every push to fill in my password.

I know this has to do with the osx credentials keychain helper which I’m fiddling with now.