Wercker S3 pipeline :error while building

#1

Am updating my website after a few months and now my wrecker build fails. Below are the logs and I cant point out what the error. Could somebody tell me what might be wrong here? Thank you.

Below is the wrecker.yml

box: debian
build:
  steps:
    - arjen/hugo-build:
        version: "0.19"
        theme: "beautifulhugo"
        disable_pygments: true

deploy:
  steps:
    - s3sync:
        key-id: $AWS_ACCESS_S3_KEY_ID
        key-secret: $AWS_ACCESS_S3_KEY_SECRET
        bucket-url: $AWS_S3_BUCKET_URL
        source_dir: public/
        opts: --acl-public --add-header=Cache-Control:max-age=3600

And the link to my website is : https://github.com/senthilthyagarajan/stencilled.me

#2

It is in the last line.

You might want to post your wrecker build file to find help. Check out Requesting Help.

#3

@maiki Sorry but I still am unable to make which file or directory . This was working fine until few months ago. And this works fine locally as well.

Thank you.

#4

@senthil_thyagarajan we can’t assist you without seeing the code you are using. Read that thread about requesting help and post the information needed to get help. :slight_smile:

#5

@maiki I just shared my code and updated the original post.

#6

I believe @ArjenSchwarz created this pipe, so perhaps he is the best person to ask about this…

#7

@senthil_thyagarajan I can see the problem. I made some major changes to the pipeline when Wercker changed the way steps are created and put that into a 2.0 release. This includes dropping support for Wercker versions older than 0.20.5 because the file names were different then.

There are two ways to solve this for you:

  1. Update the version tag to use a newer version of Hugo. It’s at 0.46 now so you can enjoy lots of new features. version: “0.46”
  2. Use an older version of the Wercker step by setting it to arjen/hugo@1.29:
#8

When I updated the version to 0.46 here is the log

Running the Hugo command
/pipeline/hugo-build-73861991-4c93-45b1-983a-568d97e97304/bin/hugo_0.46 --source=/pipeline/source/  --theme=beautifulhugo
Error: While parsing config: (32, 2): duplicated tables

wrecker.yml

box: debian
build:
  steps:
    - arjen/hugo-build:
        version: "0.46"
        theme: "beautifulhugo"
        disable_pygments: true

deploy:
  steps:
    - s3sync:
        key-id: $AWS_ACCESS_S3_KEY_ID
        key-secret: $AWS_ACCESS_S3_KEY_SECRET
        bucket-url: $AWS_S3_BUCKET_URL
        source_dir: public/
        opts: --acl-public --add-header=Cache-Control:max-age=3600
#9

I suspect that is a Hugo error. Looking at your config.toml I see there is a typo in one of your menu definitions where it’s missing a [. I’m not currently near a computer so I cant try it myself, but I suspect that if you fix that the error will go away.
If you can do so right now, you might also want to run the Hugo build locally on your computer (using the same/latest Hugo version) to see if the error shows up there as well.

1 Like
#10

@ArjenSchwarz takes 15 months off the forums. I tag him in a post, and he responds in < 2 hours. Awesome. Thanks!

2 Likes
#11

So this is what I get now :

INFO: Retrieving list of remote files for s3://www.stencilled.me/ ...
ERROR: SSL certificate verification failure: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:661)
#12

Interesting. This is an issue with the s3sync module connecting to the S3 endpoint, possibly not having the latest SSL certs or something like that. Can you try changing the wercker.yml config for your s3sync to use the step arjen/s3sync instead of s3sync? The version difference of the underlying tool between the two is only a .1, but I’ve been using that one and it works for me.
Please let me know how it goes so we can look further if it doesn’t work.

2 Likes
#13

I really didnt change on my s3 endpoint . Now I get this error

INFO: Compiling list of local files...
INFO: Running stat() and reading/calculating MD5 values on 130 files, this may take some time...
INFO: Retrieving list of remote files for s3://www.stencilled.me/ ...
INFO: Forwarding request to us-east-1
ERROR: S3 error: 403 (SignatureDoesNotMatch): The request signature we calculated does not match the signature you provided. Check your key and signing method.

finished s3 synchronisation
#14

IT WORKED !!! IT WORKED !!!

Updated key id and secret and IT WORKED !!!

Thank you @ArjenSchwarz and @rdwatters :slight_smile:

1 Like