Themes README.md missing the noEmptyLineBeforeBlock option?

Hi

I have a question:
Should the content of a themes README.md rendered with the noEmptyLineBeforeBlock option in order to be as close as GitHub Flavored Markdown?
How could a theme author configure that?

Background:
There is the blackfriday option:

[blackfriday]
extensions = [“noEmptyLineBeforeBlock”]

default: disabled
Purpose: When enabled, no need to insert an empty line to start a (code, quote, ordered list, unordered list) block.

From https://gohugo.io/contribute/themes/

Your theme’s README file should be written in markdown and saved at the root of your theme’s directory structure. Your README.md serves as

  • Content for your theme’s details page at https://themes.gohugo.io
  • General information about the theme in your GitHub repository (i.e., it’s usual purpose)

In GitHub Flavored Markdown there is no need to insert an empty line to start a list.
So in the README.md for GitHub we see
This is
* a simple
* test

as a list, while in a content of a theme’s details page we get all on one line.
This is * a simple * test

Is the issue that a theme author would write their readme in GFM, without the extra lines, and therefore their pages in the theme showcase don’t render correctly?

Yes.
And the “preview” check is also done in GFM (via browser). So it’s a bit “surprising” that the rendering is not the same …
The readme is not part of the content and a public theme shall be deployed to github - so GFM is kind of relevant for this file …

Actually looks like it becomes part of the blackfrayday rendered content:
https://github.com/gohugoio/hugoThemes/blob/master/buildThemeSite.sh

# ~~~ cut ~~~
./generateThemeSite.sh ${BASEURL}
# ~~~ cut ~~~
hugo --quiet -s hugoThemeSite/themeSite -b ${BASEURL}
# ~~~ cut ~~~

with
https://github.com/gohugoio/hugoThemes/blob/master/_script/generateThemeSite.sh

# ~~~ cut ~~~
if [ -f "${themesDir}/$x/README.md" ]; then
fixReadme ${themesDir}/$x/README.md >> themeSite/content/$x.md
# ~~~ cut ~~~

So we could have in the exampleSite dir

config.toml

[blackfriday]
extensions = ["noEmptyLineBeforeBlock"]

But this affects all md files - not just this one themeSite/content/$x.md (with $x being the root folder name of the theme)

We have:

Blackfriday flags must be grouped under the blackfriday key and can be set on both the site level and the page level. Any setting on a page will override its respective site setting.

What I don’t get:

How can i actually do:

Any setting on a page will override its respective site setting.

for the themeSite/content/$x.md “Page” ?:thinking:

It may be a good idea for an author to test the results of blackfriday on the README.md.
I do for now:

cd exampleSite/content/
ln -s ../../README.md 

Thx to @kaushalmodi

So I now just add
+++
[blackfriday]
extensions = [“noEmptyLineBeforeBlock”]
+++

in the theme README.md

This way the rendered markdown is more similar for GFM and blackfriday …