Hugo

Theme ananke doesn't work? quick start should be revised?

Hi,

New guy to Hugo and want to set it up in couple of seconds as it claims.
By following the quick-start step by step, I failed with one hour spending, frustrating …:blush:

After installation, adding theme, the guide says echo 'theme = "ananke"' >> config.toml, it doesn’t work until I found in the ananke github the config file , I should copy the config.toml to overwrite the existing one. (By the way, the ananke github official instruction says git submodule to themes/ananke but actually its config.toml use theme = "gohugo-theme-ananke" ).

Then, I start hugo server, the page I got is so ugly :slight_smile: , I don’t know what is missing.
Thanks

Hi,

I have just created a new site following the Quickstart guide exactly and have found no problems. Did you follow the steps exactly?

We don’t know that either, without knowing what your code looks like, and the exact steps you took. Have a look at Requesting Help to see how to make it easier to ask for help.

1 Like

Hi thank you for your reply.
Let me break down how I did:

  1. hugo env produce this:

Hugo Static Site Generator v0.59.1-D5DAB232 linux/amd64 BuildDate: 2019-10-31T15:21:02Z
GOOS=“linux”
GOARCH=“amd64”
GOVERSION=“go1.13.1”

git version
git version 2.17.1

  1. hugo new site quickstart, the output is

Just a few more steps and you’re ready to go:

  1. Download a theme into the same-named folder.
  1. cd quickstart, then

git init
git submodule add https://github.com/budparr/gohugo-theme-ananke.git themes/ananke
echo ‘theme = “ananke”’ >> config.toml
hugo new posts/my-first-post.md

  1. start the server by hugo server -D --bind=0.0.0.0 --verbose, output is

hugo server -D --bind=0.0.0.0 --verbose
INFO 2019/11/10 19:05:51 Using config file:
Building sites … INFO 2019/11/10 19:05:51 syncing static files to /

               | EN  

±-----------------±—+
Pages | 10
Paginator pages | 0
Non-page files | 0
Static files | 3
Processed images | 0
Aliases | 1
Sitemaps | 1
Cleaned | 0

Total in 10 ms
Watching for changes in /home/ajee/quickstart/{archetypes,content,data,layouts,static,themes}
Watching for config changes in /home/ajee/quickstart/config.toml
Environment: “development”
Serving pages from memory
Running in Fast Render Mode. For full rebuilds on change: hugo server --disableFastRender
Web Server is available at http://localhost:1313/ (bind address 0.0.0.0)
Press Ctrl+C to stop

  1. access via Chrome by 10.10.10.1:1313, get screen as below. access localhost:1313, the same. console has nothing output during the accessing.

Hugo sez:

Web Server is available at http://localhost:1313/

You sez:

access via Chrome by 10.10.10.1:1313

10.10.10.1 IS NOT localhost. (well, it might be if localhost points to 10.10.10.1 but it in fact is NOT localhost because only localhost can be localhost, not something that pretends to be localhost. If you get my drift :wink:

Does it look ok when you load localhost:1313? Does localhost NOT load at all?

“Normally” computers don’t have 10.10.10.1 as local address, so you might have issues with the quickstart. Have a look at the baseURL setting in config.toml (not sure if that is the right one, but I guess it needs to point to 10.10.10.1 instead of what it points to now).

Hmm, I just read the “access localhost:1313, the same. console has nothing output during the accessing.” part, sorry :wink:

So, except for the black color in the header area your result looks quite similar to the one you posted inthe top? What would you expect to see? You only created a post without any content in content/my-first-post.md. Open that file, add some text after the last --- line and it will appear on your test site.

Thank you for your reply :slightly_smiling_face:
What I expect to see is the beautiful theme of ananke, as its github README shows. This is my first touch of hugo and I wish to see using theme is simple and easy to change from one to another …

To set the background image in the header you need to add a parameter to the config.

[params]
  featured_image = "/images/gohugo-default-sample-hero-image.jpg"

This is a setting specific to this theme. Most Hugo themes but the most basic ones will have theme specific settings. Hopefully they are explained in the theme documentation.

So it you are using Hugo together with a contributed theme you will need to read Hugo documentation plus the themes own documentation.

I think you will have to follow all the explanations in that README starting at https://github.com/budparr/gohugo-theme-ananke#getting-started to modify it to your wishes. The status you get after following the quickstart only installs the theme with a couple of default settings. Fonts, hero image and so on need to be changed after that.

Maybe the theme should show in their README file how it looks like without any modifications after installation before it shows what you can achieve with it.

2 Likes

OK, I got it. Try with other themes by following their detailed instructions it works well.
Thank all.