The website is not rendered with Stack-starter theme

Hi community, I see a lot of issues about site not rendering, but browsing through them didn’t help me. I am using github actions to deploy my website. I am using a Stack-Starter theme.

Steps:

  • developed contents of the website
  • baseurl pattern I use is “https://name.github.io/
  • ran “hugo” locally, public folder was created
  • pushed everything to remote. Actions succeeded.
  • the website is not rendered as expected. I see only the root README.

The link to the repo.

I will be very grateful if anybody could take a look. Thanks in advance :slight_smile:

Our documentation provides a suggested setup for hosting on GitHub Pages:
https://gohugo.io/hosting-and-deployment/hosting-on-github/

I’ve used it many times; works great.

Why don’t you try that first?

maybe it’s one quick fix: the baseURL for a GitHub repository pages site is https://USERNAME.github.io/REPOSITORY/

else I would recommend to follow @jmooring and try out the starter

Hi @jmooring and @irkode, thank you for quick reply. And thank for the docs link, tried to change my deploy.yaml to the default hugo.yaml from the link you provided. Actions succeeded but nothing changed :frowning:

I also tried to add REPOSITORY to my baseurl but it also had no impact unfortunately. I ran out of ideas what else I can try. Will be happy if you can give me an advise. Thanks in advance :slight_smile:

Did you follow all of the directions, including steps 3 and 4?

Check your GitHub Pages setup:

  • actions
    looks like your build action builds with jekyll
    Sometimes you need to unpublish your site an then activate it again choosing your workflow

  • settings → Pages

  • Github docs

    Profile page vs repository page

    Dunno exactly what kind you try build.

Here’s your site hosted on GitHub Pages:
https://jmooring.github.io/ieboytsov.github.io/

This commit shows my changes:
https://github.com/jmooring/ieboytsov.github.io/commit/e8d3a60cca7f4c72ba8b1a926cd9a952dc2d3832

Thank you for your help guys @jmooring @irkode Appreciate it very much. It works now, i didn’t notice the branch name was master, but not main.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.