Stylesheet not appearing

I have seen a ton of people ask about this, but none of the proposed solutions are working for me. When running the hugo server, everything looks good.

Then I run hugo and build the public directory, click on index.html, and no styling appears and all the page links are broken.

Here is the repo GitHub - mvyleteljr/decentralized-website: attempt to make decentralized personal website

Please help

So you have no intention of hosting the contents of the public directory on a web server, is that correct?

I plan to host it on IPFS with an ENS domain name, hence the dencentralized-website repo name

in short, I fully plan on hosting the contents of the public directory on a web server. just not a traditional one

The theme you are using only uses absolute url (why? no idea!) so every link invocation will start with your baseURL, (…

You could hack your way by using / as baseURL.

Tried that… didn’t work unfortunately.

The browser console will help you identify the problems.

Step 1 - Change site configuration

baseURL = "/"
relativeURLs = true
uglyURLs = true

That will fix some of the links, but now CSS and JS are blocked by CORS policy:

Step 2 - Bypass CORS policy by opening from command line

google-chrome --allow-file-access-from-files public/index.html

That will get us something that looks OK, but links will be broken…

Then you need to look at your menu items and every URL in every layout in the theme.

Thanks for the response.

The command line prompt you offered isn’t working on my Mac. I will continue to trouble shoot… I don’t have a bash command for google-chrome

/Applications/Google\\ Chrome --allow-file-access-from-files public/index.html