[SOLVED] Errors in deployment with Netlify

I’m trying to deploy my blog at Netlify and i’m getting some errors, like:

6:24:45 PM: ERROR: 2017/07/07 21:24:45 hugo.go:421: Current theme does not support Hugo version 0.17. Minimum version required is 0.2
6:24:45 PM: Started building sites ...
6:24:45 PM: ERROR: 2017/07/07 21:24:45 template.go:477: template: theme/partials/footer.html:4: function "now" not defined
6:24:45 PM: ERROR: 2017/07/07 21:24:45 template.go:132: template: "theme/partials/footer.html" is an incomplete or empty template; 

And at the end I get:

6:24:47 PM: Build complete: exit code: 255
6:24:47 PM: Cleaning up docker container
6:24:47 PM: Error running command: Build script returned non-zero exit code: 255
6:24:47 PM: An error occurred while building the site, skipping the deploy and cache refresh.
6:24:47 PM: Build script returned non-zero exit code: 255
6:24:48 PM: Finished processing build request in 8.048248515s

Which doesn’t let the website work. I don’t really know how to fix these problems. Anyone can help me?

The folders are in: https://github.com/brunaw/brunaw.github.io

At a glance, it looks like you need to tell Netlify which version of Hugo to use:

1 Like

Not sure why Netlify stil has Hugo 0.17 as the default version. Your theme requires >= 0.20.

This article describes it: https://www.netlify.com/blog/2017/04/11/netlify-plus-hugo-0.20-and-beyond/

One simple ways is to set an envronment variable HUGO_VERSION to 0.25 (which is the latest) in the Netlify site definition.

@bep @budparr How exactly do I change it on Netlify?

Before deploying the website, I can only fill the following:

Deploy settings for brunaw/brunaw.github.io > branch to deploy

Basic build settings > Build command 
Basic build settings > Publish directory

And the Advanced build settings.

Settings > Build environment variables, Edit, hit the plus sign, add key HUGO_VERSION with value 0.25.

@bep It worked! thanks!

Now i’m trying to change the domain, but when I try to use brunaw.netlify.com or any other domain, I get:
conflicts with an SSL certificate installed by another user

Do you know what is this about?

This sounds like a question you need to take with Netlify.

true, thanks :slight_smile:

I was having the same error Build script returned non-zero exit code: 255 even after I put the HUGO_VERSION parameter. But, I discover that the Netlify doesn’t support hugo sass compilation yeat.