OT: The site mounts in local but it does not load in browser

I had no problem in opening the site in the browser through the default URL http://localhost:1313/ after mounting it using Hugo Server.

Then suddently it stopped updading the new version in the browser even after succesfuly mounting a new version of the site in local, so I removed the cache thinking that perhaps this was the problem.

Now the site does not open in the browser. It just stays forever loading. I have tried incognito. I have tried other browsers. I have tried other computers. I have installed latest Hugo version. However, it is not only the most current version of my site that will mount correctly but not load in the browser but even those that were working fine before.

The theme is: educenter from themefisher

I would really appreciate any clue on what may be happening.


Please see Requesting Help.

Include a link to the source code repository of your project, because we really need the context of seeing your templates and partials to be able to help you. It is trivial to do a quick git clone on your repo, then run hugo server in your project, to help you out. On the other hand, recreating your code from screenshots, or sort of guessing at it, is not.

If you can’t share your repository for whatever reason, consider creating a dummy repo that you can share, which reproduces the problem you’re experiencing.

Thanks for letting me know:

hugo v0.81.0+extended darwin/amd64 BuildDate=unknown


Have a look at the browser console and start troubleshooting.

Thanks jmooring,

All these errors are from the original theme as I also get them when I install the theme unmodified.

Were you able to see the site on your browser?

What I fail to understand is how was it possible that it worked yesterday and it has been working for days while I was modifying the original theme and then suddently it stopped working not just my version but even the original theme? Any clues on that?


I did not see these errors when I created a new site using this theme.

We do not offer support for general web development in this forum.

Your issue appears to be Off Topic in this forum since as per the above screenshot you are missing a JS library. You need to ask at the repository of the theme you are using for support about its JS assets.

Thank you for the understanding.