Mod and modBool not working with JSON data

I have a basic JSON file that increments with each addition like so:
...
{
"id": 1,
"blah": "some text"
},
{
"id": 2,
"blah": "some more text"
} ...

I’m able to access the id’s by using the range function like so:

{{ range $.Site.Data.myJSON }}
{{ .id }}
{{ end }}

BUT, it won’t let me perform mod or modBool functions on them such as:

{{ mod .id 2 }}

The result of the line above doesn’t work… The page renders to it’s last known working state.
However, I can do other math functions with the ids, like:

{{ add .id 1 }}

So it knows the id is an integer if I can use the add function on it, but I’m stumped as to why it won’t let me do mod or modBool? I tried both of these without using my id with the following examples:

{{ mod 1 2 }}

{{ modBool 1 2 }}

which give results of 1 and false, respectively. So the functions work, just not on the integers I’m pulling from the JSON apparently. What am I missing here?

Thank you

This was fixed in Hugo v0.31.

Thank you. Updating hugo fixed it