Image not deploying

An image (jpg) I have for a particular post renders perfectly when running under localhost. But after deploying it doesn’t show up and the image description displays instead. I have other images in different post and they all show up as expected. I’ve tried taking a new photo, thinking there must be something wrong with the first one, with the same result. I’m using ananke theme. My image did get copied to the website along with the other images.

There is nothing different with this post or the image. Frankly, this baffles me and I don’t see a similar problem when searching for an answer. Any insight would be appreciated.

Can you share your project?


Let us see your code

Include a link to the source code repository of your project, because we really need the context of seeing your templates and partials to be able to help you. It is trivial to do a quick git clone on your repo, then run hugo server in your project, to help you out. On the other hand, recreating your code from screenshots, or sort of guessing at it, is not.

If you can’t share your repository for whatever reason, consider creating a dummy repo that you can share, which reproduces the problem you’re experiencing.

1 Like

The problem was not a Hugo issue at all. The images not deploying were those with stricter file permissions. I don’t know why some images have certain permission settings and other have stricter. I just had to make sure the permissions were set correctly on my web server.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.