Hugo not rendering title / date anymore

#1

So I recently switched distros, and moved my content over to the new box. Sadly I don’t remember the version of Hugo I was running, but now I’m running 0.42. Before the move my main page would render my posts in the following format:

Title1 / publish date
Title2 / publish date

Now it renders as

Title1 / description
Title2 / description

I can see the source on the main page is using post-stub-description. I would think it would be post-date but obviously I don’t want to edit this by hand every single time. I’m just not sure where its generated from as I’m very new to Hugo:

         <li class="post-stub">
 <a href="https://fubar.com/2018/04/16/foo/">
     <h4 class="post-stub-title">Foo &#43; Bar</h4>
     
         <p class="post-stub-description">Crappy description</p>
     
     
 </a>
 </li>

If someone could tell me how to change it back I would be much obliged.

Thanks

#2

I also recently downgraded to 0.42 It didn’t change my list display. What theme are you using?

#3

Please read Requesting Help and include more information, particularly the theme and your site’s project. :slight_smile:

#4

I’m using the Ghostwriter theme. The project is no longer available via the web, its offline atm.

#5

So I spun up a Debian box which uses 0.18.1 and that fixed the issue. Which I don’t really understand.

#6

So lots has changed in Hugo between version 0.18 and 0.49, there’s probably something in the theme which no longer works.

Options:

  1. Link to your project’s code (github?) so the community can have a look and see where things are going wrong.
  2. Use a theme which is being actively developed. There is a theme named Ghostwriter available that’s been updated recently.