HUGO

Having trouble hosting blog on Netlify, unclear issues

Having some trouble with Hugo and Netlify, was hoping someone could help a beginner out. Getting the following warning on local host:

WARN 2020/06/30 20:41:34 Module “meme” is not compatible with this Hugo version; run “hugo mod graph” for more information.This seems to suggest I need to change the Hugo version, how do I do that?

Secondarily, when I try to up the site on Netlify, I get the error:

7:09:29 PM: Error checking out submodules: Submodule 'themes/meme' (https://github.com/reuixiy/hugo-theme-meme.git) registered for path 'themes/meme'
Cloning into '/opt/build/repo/themes/meme'...
fatal: remote error: upload-pack: not our ref afe49dfdbea868117ec3d0189ca1a3d031ccee1d
fatal: the remote end hung up unexpectedly
Fetched in submodule path 'themes/meme', but it did not contain afe49dfdbea868117ec3d0189ca1a3d031ccee1d. Direct fetching of that commit failed.

Is there some configuration option I need to go toggle?

My repo is hosted at https://github.com/thor314/meme-blog in case that’s useful.

The commit for the theme you checked out doesn’t exist in the repo:

https://github.com/reuixiy/hugo-theme-meme/tree/afe49dfdbea868117ec3d0189ca1a3d031ccee1d

Maybe update your submodule pointer, or whatever (I don’t use submodules, forget what it’s called). Or check if Netlify has a different method for including a theme, such as a module: https://gohugo.io/hugo-modules/

Oh, that’s a really good hint, thanks @maiki. I figured out that I totally screwed up the submodule. I needed to delete it and reinstall it (though I guess I could have just rebased and gotten rid of some commits) to fix the sitch. Thanks!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.