Has the -F flag been disabled?


I seem to be unable to get my page rendered in the future using the -F flag.
issues seem to been occurring in both of these versions

==> Upgrading 1 outdated package:
hugo 0.82.1 -> 0.83.1


date: 2021-05-13T14:00:00+09:00

When I set it back to a past date the page renders correctly. I am just in the process of composing my post.

No, the -F flag has not been disabled.

I am unable to reproduce the problem with v0.83.1.

What else is in the front matter for this page?

Is draft set to true?

title: "Swift: Deconstruct Spf an Outline and Background"
#subtitle: Learning Swift by trying to make a simple 
date: 2021-05-13T14:00:00+09:00
  - learning swift by deconstructing spf
  - coding
  - learning
  - swift
  - learning
  - spf
  - dns

I am running under Mac OS, Catalina
I am sure this was not a problem in earlier versions, But I had actually stopped using the -F flag for a while.
I am located in Tokyo, so the time the time at this writing is 13th, 13:33

hugo -F server
port 1313 already in use, attempting to use an available port
Start building sites … 

                   | EN   
  Pages            | 371  
  Paginator pages  |  12  
  Non-page files   |   0  
  Static files     | 205  
  Processed images |   0  
  Aliases          | 164  
  Sitemaps         |   1  
  Cleaned          |   0  

Built in 253 ms
Watching for changes in /Users/aspann/Documents/Development/hugo/bas-man.github.io/{archetypes,content,data,layouts,static,themes}
Watching for config changes in /Users/aspann/Documents/Development/hugo/bas-man.github.io/config.toml, /Users/aspann/Documents/Development/hugo/bas-man.github.io/config/_default, /Users/aspann/Documents/Development/hugo/bas-man.github.io/config/_default/menus
Environment: "development"
Serving pages from memory
Running in Fast Render Mode. For full rebuilds on change: hugo server --disableFastRender
Web Server is available at http://localhost:51345/ (bind address
Press Ctrl+C to stop

I think I just spotted my problem

I had another Hugo instance running. Smack!

Sorry for taking up peoples time.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.