Errors while building site after updating content - solved by version 0.93.1

Hello Hugo professionals!

Need some help please. Two days ago I was able to build my updated page (only content updates) and since today I get the following errors:

Start building sites …
hugo v0.93.0+extended linux/amd64 BuildDate=unknown
ERROR 2022/03/02 13:49:39 render of "page" failed: "/home/fh/repos/hmbrg.xyz/layouts/_default/single.html:4:21": execute of template failed: template: _default/single.html:4:4: executing "main" at <partial "tags.html" .>: error calling partial: execute of template failed: template: partials/tags.html:4:21: executing "partials/tags.html" at <apply (sort .) "partial" "link" ".">: error calling apply: called apply using string as type context.Context
ERROR 2022/03/02 13:49:39 render of "page" failed: "/home/fh/repos/hmbrg.xyz/layouts/_default/single.html:4:21": execute of template failed: template: _default/single.html:4:4: executing "main" at <partial "tags.html" .>: error calling partial: execute of template failed: template: partials/tags.html:4:21: executing "partials/tags.html" at <apply (sort .) "partial" "link" ".">: error calling apply: called apply using string as type context.Context
ERROR 2022/03/02 13:49:39 render of "page" failed: "/home/fh/repos/hmbrg.xyz/layouts/_default/single.html:4:21": execute of template failed: template: _default/single.html:4:4: executing "main" at <partial "tags.html" .>: error calling partial: execute of template failed: template: partials/tags.html:4:21: executing "partials/tags.html" at <apply (sort .) "partial" "link" ".">: error calling apply: called apply using string as type context.Context
ERROR 2022/03/02 13:49:39 render of "page" failed: "/home/fh/repos/hmbrg.xyz/layouts/_default/single.html:4:21": execute of template failed: template: _default/single.html:4:4: executing "main" at <partial "tags.html" .>: error calling partial: execute of template failed: template: partials/tags.html:4:21: executing "partials/tags.html" at <apply (sort .) "partial" "link" ".">: error calling apply: called apply using string as type context.Context
Error: Error building site: failed to render pages: render of "page" failed: "/home/fh/repos/hmbrg.xyz/layouts/_default/single.html:4:21": execute of template failed: template: _default/single.html:4:4: executing "main" at <partial "tags.html" .>: error calling partial: execute of template failed: template: partials/tags.html:4:21: executing "partials/tags.html" at <apply (sort .) "partial" "link" ".">: error calling apply: called
apply using string as type context.Context

Link to my website:
Git repo of my website:

Only changes I made was regarding content.

Looks like you hit this issue:

Already fixed, but not yet released.

2 Likes

Perfect, then I’ll wait for the next release of Hugo. Thanks for clarification, highly appreciated.

1 Like

Sorry for the noise … This is fixed here: Release v0.93.1 · gohugoio/hugo · GitHub

3 Likes

Nice! Then it should hit my package manager very soon :smile:

2 Likes

Can confirm that everything is working as expected after updating to Hugo 0.93.1. Special thanks to @bep who fixed this issue!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.