Asciidoc generation quit working, multiple platforms [SOLVED]


#1

I’ve now created two static sites using Hugo & creating .adoc “source” files using Asciidoc format and the asciidoc capabilities within Hugo. Worked great, and they’ve both been running for a week or more.

Today I wanted to add a post, so I cd’ed to the site directory & ran hugo server…and I get errors on every Asciidoc document. I’ve tried this on both Mac (the original platform) & Ubuntu Linux…and both fail.

What happened? How can I diagnose & resolve this? Any and all assistance greatly appreciated.

Cheers,
Mark


#2

From the Linux machine, I get these errors:

ERROR 2019/01/09 14:24:32 post/portable-iot-demo.adoc: asciidoc: ERROR: unsafe: ifeval invalid
ERROR 2019/01/09 14:24:32 post/portable-iot-demo.adoc: asciidoc: FAILED: ifeval invalid safe document
ERROR 2019/01/09 14:24:32 /usr/bin/asciidoc rendering post/portable-iot-demo.adoc: exit status 1

(for every post)


#3

Solved it on Mac, it somehow became linked (update?) to an older version of asciidoctor. Still seeing the same errors on the Ubuntu box though. :confused:

Solution on Mac (using homebrew): brew install asciidoctor (after installing asciidoc, of course)


#4

Solved. Even though the Linux error messages aren’t as helpful, doing a sudo apt-get install asciidoctor (in addition to installing asciidoc) solves it. Whew.

Leaving this question+replies in hopes it helps someone else. Sorry to clutter, cheers.