Additional forward slash in published files


I am a newbie to hugo. I am publishing to github, then over to AWS. When I try clicking on any post it appears that there is an additional forward slash at the end of each one. This doesn’t happen when I run locally, only after I publish using the ‘hugo’ command. I can see that my file contains an additional / for every link.

Here’s my website:

Here’s my github:

For example, go to my index.html under public.

Any ideas? I have been going through the config.toml but cannot see where I am entering an additional /

Thank you!

Any ideas

I think its that in your config

  posts = "/:year/:month/:day/:slug/:"

What’s the /: on the end?

You may want this

  posts = "/:year/:month/:day/:slug"

as here is your link:

:year - /2016/
:month - /07/
:day - /04/
:slug - /independence-day-sunset/
: - ??? that will generate as //, nothing between / as you do not specified what : shall do.


Perfect, thank you @idarek ! That worked :smiley:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.